TP-Link WR941N刷OpenWrt固件教程

硬件版本 TP-Link WR941N V4/V5 00000000,软件版本 3.11.7 build 100723,从 OpenWrt trunk(OpenWrt trunk地址:http://downloads.openwrt.org/snapshots/trunk/ar71xx/)下载对应固件 openwrt-ar71xx-generic-tl-wr941nd-v4-squashfs-factory.bin。

其他型号参考 Table of Hardware地址http://wiki.openwrt.org/toh/start下载固件。

TP-Link WR941N刷OpenWrt 刷机过程:

1、登录路由器升级固件,待路由自动重启后 telnet 192.168.1.1 连上路由器,passwd 设置密码,之后就可以通过 ssh root@192.168.1.1 登录路由器。

2、开启OpenWrt无线网络

OpenWrt 默认没有开启无线网络,参考 TP-Link TL-WR941ND(http://wiki.openwrt.org/toh/tp-link/tl-wr941nd)手动修改

vi /etc/config/wireless (修改之前最好备份一下配置文件)

config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11ng
option path 'pci0000:00/0000:00:00.0'
option htmode HT20
list ht_capab SHORT-GI-40
list ht_capab TX-STBC
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
# option disabled 1 (删除或注释这一行)

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption psk (默认没有加密,修改为 psk)
option key xxxxxxxxx

重启路由网络:
/etc/init.d/network restart

3、配置 PPPoE

vi /etc/config/network

config interface 'wan'
option ifname 'eth1'
option proto pppoe
option username 1234567
option password 7654321
option macaddr xx:xx:xx:xx:xx:xx (克隆路由器网卡地址)

4、再次重启路由网络进行拨号。

5、安装 LuCI web 界面,这样就可以在浏览器操作路由:

opkg update
opkg install luci
/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start

现在就可以通过 http://192.168.1.1 修改路由器配置。

6、如果网络修改失败不能 ssh 登录,可以进入安全模式恢复:

路由上电时,灯会全亮一下,这时你要全神贯注了,当sys灯再次亮时,要立刻按reset2-3秒,然后你就会发现sys灯快闪了。这说明,安全模式成功了!

本机 IP 改为 192.168.1.5,telnet 192.168.1.1 连上,然后 firstboot 恢复。

原文地址:
http://fann.im/blog/2012/11/29/tp-link-wr941n-flash-openwrt/
http://www.server-x.org/index.php/tp-link-tl-wr941n-ver-5-1安装openwrt过程/

This entry was posted in Technology and tagged , , , , . Bookmark the permalink. 30,133 views

Related Posts

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>