WordPress屏蔽后台版本和插件的升级提示

一、屏蔽核心代码升级提示:

方法一:

找到 wp-admin/includes/下的“update.php”文件,然后搜索

echo "<div class='update-nag'>$msg</div>";

可以找到两处,然后将其注释掉,也就是修改为 //echo "<div class='update-nag'>$msg</div>";

方法二:

找到 wp-admin/css/ 下的“wp-admin.css”文件,然后搜索“update-nag”

在后面的属性里添加“display: none;”

方法三:、打开wp-includes/version.php修改$wp_version的值

如目前最高版本号为3.6,只要比3.6高即可,例如改为5.0或者23.0等等。

方法四:

把下面的代码

add_action('admin_menu','wp_hide_nag');
function wp_hide_nag() {
remove_action( 'admin_notices', 'update_nag', 3 );
}

添加到主题的 functions.php 即可隐藏WordPress后台版本升级提示

二、屏蔽插件升级提示:

找到 wp-admin/css/ 下的“wp-admin.css”文件,然后搜索“update-plugins”

可以找到很多,找到一个后面带有“display:block”的那个,然后更为“display:none”

Related Posts

3 thoughts on “WordPress屏蔽后台版本和插件的升级提示”

Leave a Reply

Your email address will not be published. Required fields are marked *